quarta-feira, 16 de janeiro de 2013

Configuração da Nuvem MPLS em Provedores

Olá Pessoal.

Esse post traz um assunto relevante no contexto atual das telecomunicações que é o MPLS. Atualmente a tecnologia MPLS (Multi-Protocol Label Switching) é comumente utilizada pelas operadoras de telecomunicações (ISP) como solução de conectividade de longa distância.

E antes de entrar na discussão técnica, uma primeira observação importante é que a configuração dessa tecnologia no ambiente corporativo (enterprise) é totalmente diferente da configuração na nuvem da operadora (ISP). 

Aliás, quem possui um link MPLS na empresa sabe bem que ela é transparente, já que você simplesmente recebe a conectividade da operadora e pronto - é como se houvesse um link privado entra as unidades remotamente conectadas... Bom, então se a coisa é simples assim qual seria a razão da "novela" que se faz acerca dessa tecnologia?

A simplicidade de uns é a complexidade de outros! Os roteadores instalados na empresa cliente normalmente sequer têm noção do que é MPLS e por isso toda a complexidade da infraestrutura está na nuvem da operadora.

Diferente de outras tecnologias de Camada 2 (HDLC, ATM e Frame-Relay) que eram tradicionalmente utilizadas na longa distância (e ainda são), o MPLS surgiu como uma tecnologia de Camada 2¹/² que traz uma abordagem de operação totalmente nova: o chamado roteamento baseado em rótulos.

Essa tecnologia não utiliza mais o cabeçalho do datagrama IP na decisão de roteamento, fazendo o reencapsulamento do datagrama com um novo cabeçalho de 4 bytes que possui um rótulo de 20 bits. Toda a decisão de encaminhamento dos pacotes é determinada com base nesse rótulo, o que agiliza o processo de roteamento e permite a implementação de técnicas de engenharia de tráfego, entre outras coisas mais.

O assunto é extenso e obviamente que o meu objetivo não é substituir um bom livro sobre o assunto - por isso serei o mais objetivo possível e o foco é que vocês consigam reproduzir um cenário prático de MPLS. Vamos trabalhar com o  cenário observado na figura abaixo. 



Antes de partir para a configuração, existem vários conceitos fundamentais que o leitor precisa ter em mente para entender o papel dos elementos envolvidos no cenário. Então que tal começar pelo começo? Parece razoável... ;-)

O Custormer Edge (CE) é o equipamento instalado nas unidades remotas da empresa que irão receber a solução de conectividade provida pela operadora. Outro elemento importante é o Provider Edge (PE) que se trata do roteador da operadora diretamente conectado a um (ou mais) roteador(es) do(s) cliente(s), ou seja, PEs são conectados a CEs. Por fim, o elemento P (Provider) são os demais roteadores distribuídos pela nuvem MPLS que representa a infraestrutura de rede da operadora.

Outro conceito fundamental é a tecnologia VRF (Virtual Routing and Forwarding) que traz consigo outros dois elementos igualmente importantes: o RD (Route Distinguisher) e o RT (Route Target). Através do VRF é possível criar múltiplas instâncias da tabela de roteamento, sendo que cada uma dessas tabelas virtuais é totalmente independente das demais. No contexto do MPLS é comum que cada cliente tenha sua própria VRF porque essa prática traz mais segurança e flexibilidade

Sem as VRFs individuais o tráfego entre as sub-redes de todos os clientes da operadora iriam compor uma única tabela de roteamento, o que seria péssimo do ponto de vista de segurança. Outro benefício comum é que se torna possível que os clientes utilizem endereços de redes iguais, já que as instâncias VRF são independentes. E é muito comum que as empresas utilizem endereços privados da RFC1918 (192.168 /16, 172.16 /12 e 10 /8).

No entanto, em algum momento é necessário que as rotas entre o roteador da empresa (CE) e o roteador da operadora (PE) sejam redistribuídas para um processo BGP no PE. Isso porque deve existir um pareamento iBGP entre um PE e outro PE remoto para viabilizar na prática a chamada VPN MPLS, um túnel abstrato que só existe nas bordas da rede MPLS, já que os roteadores P sequer conhecem as várias VPNs.

Eis que surge um problema: Fica claro que é possível ter endereços repetidos através das VRFs porque elas representam tabelas de roteamento distintas, mas como fica a redistribuição das rotas iguais para o processo BGP!!!??? Isso só é possível através da adição de um identificador nas rotas para torná-las únicas que é denominado RD (Route Distinguisher). Também existe o RT (Route Target), uma community BGP que indica o membro de uma VPN, permitindo que rotas sejam importadas e exportadas das VRFs no processo de redistribuição

Há alguns formatos para o RD/RT, sendo que sua forma mais comum consiste em:  
ASN de 16 Bits + Número de 32 Bits ; Ex.: 65000:100. 

No cenário apresentado nesse post teremos duas VRFs denominadas Cliente1 e Cliente2 que serão identificadas da seguinte forma:

- VRF Cliente 1, RD 65001:111, RT 65001:1
- VRF Cliente 2, RD 65002:222, RT 65002:2

Mesmo com "toda" essa carga teórica, acreditem que fui bastante sucinto e fiz o possível para "suavizar" essa postagem apresentando apenas os conceitos fundamentais. Como o processo de configuração consiste em várias linhas de comando, estarei dividindo o processo de configuração nas seguintes etapas: 

  1. Configuração Básica das Interfaces e Endereços IP
  2. Roteamento IGP (EIGRP) na Nuvem da Operadora (AS 200)
  3. Criação e Associação da VRF e Configuração do RD/RT
  4. Configuração do Roteamento EIGRP no PE e CE
  5. Configuração da Redistribuição de Rotas EIGRP e BGP
  6. Configuração do MP-BGP no(s) PE

As etapas 1 e 2 não dizem respeito à configuração do MPLS propriamente dito, no entanto são pré-requisitos para o cenário funcionar devidamente. Como os roteadores da empresa (CE) nao têm ciência do MPLS, eles possuem apenas configurações básicas.

1) Configuração Básica das Interfaces e Endereços IP

A única configuração que merece destaque nessa primeira etapa é que estamos habilitando o encapsulamento MPLS na interface que se conecta a outro roteador da nuvem da operadora. Reparem que as interfaces que se conectam aos roteadores CE não têm essa configuração, já que o tráfego até o PE é puramente IP.

PE1(config)# int lo 1
PE1(config-if)# ip address 1.1.1.1 255.255.255.255
PE1(config-if)# int f0/0
PE1(config-if)# ip address 172.16.5.2 255.255.255.252
PE1(config-if)# mpls ip
PE1(config-if)# int s1/0
PE1(config-if)# clock rate 64000
PE1(config-if)# ip address 172.16.1.1 255.255.255.252
PE1(config-if)# no shut
PE1(config-if)# int s2/0
PE1(config-if)# clock rate 64000
PE1(config-if)# ip address 172.16.2.1 255.255.255.252
PE1(config-if)# no shut

PE2(config)# int lo 1
PE2(config-if)# ip address 2.2.2.2 255.255.255.255
PE2(config-if)# int f0/0
PE2(config-if)# ip address 172.16.6.2 255.255.255.252
PE2(config-if)# mpls ip
PE2(config-if)# int s1/0
PE2(config-if)# clock rate 64000
PE2(config-if)# ip address 172.16.3.1 255.255.255.252
PE2(config-if)# no shut
PE2(config-if)# int s2/0
PE2(config-if)# clock rate 64000
PE2(config-if)# ip address 172.16.4.1 255.255.255.252
PE2(config-if)# no shut

P(config)# int lo 1
P(config-if)# ip address 3.3.3.3 255.255.255.255
P(config-if)# int f0/0
P(config-if)# ip address 172.16.5.1 255.255.255.252
P(config-if)# mpls ip
P(config-if)# int f1/0
P(config-if)# ip address 172.16.6.1 255.255.255.252
P(config-if)# mpls ip
P(config-if)# no shut

2) Roteamento IGP (EIGRP) na Nuvem da Operadora (AS 200)

Essa segunda etapa também é bem básica, consistindo apenas na configuração de um protocolo de roteamento IGP qualquer na nuvem da operadora. Não há nenhum destaque especial, então apenas trarei os comandos:

PE1(config)# router eigrp 200
PE1(config-router)# network 172.16.0.0
PE1(config-router)# network 1.1.1.1
PE1(config-router)# no auto-summary

PE2(config)# router eigrp 200
PE2(config-router)# network 172.16.0.0
PE2(config-router)# network 2.2.2.2  
PE2(config-router)# no auto-summry

P(config)# router eigrp 200
P(config-router)# network 172.16.0.0
P(config-router)# network 3.3.3.3 
P(config-router)# no auto-summary 

3) Criação e Associação da VRF e Configuração do RD/RT

A configuração abaixo é necessária apenas nos roteadores de borda (PE), já que os roteadores da empresa (CE) não têm ciência do MPLS. Reparem que em cada roteador de borda criamos duas VRFs e informamos os valores RD/RT previamente definidos. Por fim, associamos cada VRF com sua respectiva interface (cliente).

PE1(config)#ip vrf Cliente1
PE1(config-vrf)#rd 65001:111
PE1(config-vrf)#route-target both 65001:1
PE1(config-vrf)#exit
PE1(config)#ip vrf Cliente2
PE1(config-vrf)#rd 65002:222
PE1(config-vrf)#route-target both 65002:2
PE1(config-vrf)#exit
PE1(config)#int s2/0
PE1(config-if)#ip vrf forwarding Cliente1
% Interface Serial2/0 IP address 172.16.1.1 removed due to enabling VRF Cliente1
PE1(config-if)#ip address 172.16.1.1 255.255.255.252
PE1(config-if)#exit
PE1(config)#int s2/1
PE1(config-if)#ip vrf forwarding Cliente2
% Interface Serial2/1 IP address 172.16.2.1 removed due to enabling VRF Cliente2
PE1(config-if)#ip address 172.16.2.1 255.255.255.252
PE1(config-if)#exit


PE2(config)#ip vrf Cliente1
PE2(config-vrf)#rd 65001:111
PE2(config-vrf)#route-target both 65001:1
PE2(config-vrf)#exit
PE2(config)#ip vrf Cliente2
PE2(config-vrf)#rd 65002:222
PE2(config-vrf)#route-target both 65002:2
PE2(config-vrf)#exit
PE2(config)#int s2/0
PE2(config-if)#ip vrf forwarding Cliente1
% Interface Serial2/0 IP address 172.16.3.1 removed due to enabling VRF Cliente1
PE2(config-if)#ip address 172.16.3.1 255.255.255.252
PE2(config-if)#int s2/1
PE2(config-if)#ip vrf forwarding Cliente2
% Interface Serial2/1 IP address 172.16.4.1 removed due to enabling VRF Cliente2
PE2(config-if)#ip address 172.16.4.1 255.255.255.252
PE2(config-if)#exit



4) Configuração do Roteamento EIGRP no PE e CE

A próxima etapa consiste na configuração de um protocolo de roteamento entre a empresa para que o provedor possa conhecer as rotas anunciadas pela empresa. Esse processo de configuração é bem simples nos roteadores da empresa (CE), no entanto há alguns comandos adicionais nos roteadores do provedor (PE) que são necessários para associar as rotas de cada cliente com sua respectiva VRF anteriormente criada. 

Talvez a observação mais importante aqui é que o número de AS utilizado nos processos EIGRP do CE e PE não precisam ser iguais, uma vez que na configuração EIGRP do PE há uma sub-seção de configuração para cada VRF em que devemos informar o mesmo número utilizado no processo do roteador remoto (CE). Caso contrário, as rotas dos diversos clientes seriam todas compartilhadas na tabela de roteamento padrão, o que não é desejado...

CE1A(config)#router eigrp 65001
CE1A(config-router)#network 192.168.1.0
CE1A(config-router)#network 172.16.0.0
CE1A(config-router)#no auto-summary


CE2A(config)#router eigrp 65002
CE2A(config-router)#network 192.168.1.0
CE2A(config-router)#network 172.16.0.0
CE2A(config-router)#no auto-summary  


PE1(config)#router eigrp 1
PE1(config-router)#address-family ipv4 vrf Cliente1
PE1(config-router-af)#autonomous-system 65001
PE1(config-router-af)#network 172.16.0.0
PE1(config-router-af)#no auto-summary
PE1(config-router-af)#

PE1(config-router-af)#address-family ipv4 vrf Cliente2
PE1(config-router-af)#autonomous-system 65002
PE1(config-router-af)#network 172.16.0.0
PE1(config-router-af)#no auto-summary


***

CE1B(config)#router eigrp 65001
CE1B(config-router)#network 192.168.2.0
CE1B(config-router)#network 172.16.0.0
CE1B(config-router)#no auto-summary


CE2B(config)#router eigrp 65002
CE2B(config-router)#network 192.168.2.0
CE2B(config-router)#network 172.16.0.0
CE2B(config-router)#no auto-summary  


PE2(config)#router eigrp 1
PE2(config-router)#address-family ipv4 vrf Cliente1
PE2(config-router-af)#autonomous-system 65001
PE2(config-router-af)#network 172.16.0.0
PE2(config-router-af)#no auto-summary
PE2(config-router-af)#

PE2(config-router-af)#address-family ipv4 vrf Cliente2
PE2(config-router-af)#autonomous-system 65002
PE2(config-router-af)#network 172.16.0.0
PE2(config-router-af)#no auto-summary


(*) Obs.: No processo EIGRP dos roteadores PE que irão estabelecer vizinhança com os roteadores CE utilizamos o AS 1 para não misturar as rotas dos clientes com o processo EIGRP 200 que utilizamos nas primeiras etapas para trocar as rotas internas entre os roteadores da nuvem MPLS.  

5) Configuração da Redistribuição de Rotas EIGRP e BGP

Até agora os roteadores PE já aprenderam as rotas dos clientes diretamente conectados, no entanto não existe uma ligação entre as unidades remotas dos clientes porque o PE1 não está diretamente ligado ao PE2. Ou seja, PE1 conhece as rotas anunciadas por CE1A, mas não é capaz de receber as rotas de CE1B. 

Na próxima etapa a gente vai configurar um pareamento iBGP entre PE1 e PE2 para criar a abstração do túnel da VPN/MPLS. No entanto, antes temos que configurar a redistribuição mútua entre o EIGRP estabelecido com os roteadores CE e o BGP que estará em execução nos roteadores PE.

PE1(config)# router bgp 200
PE1(config-router)# address-family  ipv4 vrf Cliente1
PE1(config-router-af)# redistribute eigrp 65001
PE1(config-router-af)# exit
PE1(config-router)# address-family ipv4 vrf Cliente2
PE1(config-router-af)# redistribute eigrp 65002
PE1(config-router-af)# exit
PE1(config-router)# exit
PE1(config)# router eigrp 1
PE1(config-router)# address-family ipv4 vrf Cliente1
PE1(config-router-af)# redistribute bgp 200 metric 10000 1000 255 1 1500
PE1(config-router-af)# exit
PE1(config-router)# address-family ipv4 vrf Cliente2
PE1(config-router-af)# redistribute bgp 200 metric 10000 1000 255 1 1500


PE2(config)# router bgp 200
PE2(config-router)# address-family ipv4 vrf Cliente1
PE2(config-router-af)# redistribute eigrp 65001
PE2(config-router-af)# exit
PE2(config-router)# address-family ipv4 vrf Cliente2
PE2(config-router-af)# redistribute eigrp 65002
PE2(config-router-af)# exit
PE2(config-router)# exit
PE2(config)# router eigrp 1
PE2(config-router)# address-family ipv4 vrf Cliente1
PE2(config-router-af)# redistribute bgp 200 metric 10000 1000 255 1 1500
PE2(config-router-af)# exit
PE2(config-router)# address-family ipv4 vrf Cliente2
PE2(config-router-af)# redistribute bgp 200 metric 10000 1000 255 1 1500



6) Configuração do MP-BGP no(s) PE
   
O último passo consiste no estabelecimento do túnel virtual entre as unidades remotas da empresa para prover ao cliente a abstração de que existe uma conexão privada de longa distância (WAN) entre as unidades. Assim que essa configuração for feita, os roteadores CE1A e CE1B vão conhecer as rotas uns dos outros e a empresa terá conectividade remota!

PE1(config)#router bgp 200
PE1(config-router)#neighbor 2.2.2.2 remote-as 200
PE1(config-router)#neighbor 2.2.2.2 update-source lo1
PE1(config-router)#address-family vpnv4
PE1(config-router-af)#neighbor 2.2.2.2 activate
PE1(config-router-af)#neighbor 2.2.2.2 send-community


PE2(config)#router bgp 200
PE2(config-router)#neighbor 1.1.1.1 remote-as 200
PE2(config-router)#neighbor 1.1.1.1 update-source lo1
PE2(config-router)#address-family vpnv4
PE2(config-router-af)#neighbor 1.1.1.1 activate
PE2(config-router-af)#neighbor 1.1.1.1 send-community


Pronto! Depois de MUITAS linhas de comando já temos uma implementação básica de VPN/MPLS funcionando entre duas empresas clientes, cada uma com apenas duas unidades remotas. Ao visualizar a tabela de roteamento VRF Cliente1 no roteador PE1 é possível observar que a rota 192.168.2.0/24 da unidade remota foi aprendida via BGP.

PE1#show ip route vrf Cliente1

Routing Table: Cliente1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.1.0 is directly connected, Serial2/0
B       172.16.3.0 [200/0] via 2.2.2.2, 00:02:37
D    192.168.1.0/24 [90/2172416] via 172.16.1.2, 00:42:44, Serial2/0
B    192.168.2.0/24 [200/2172416] via 2.2.2.2, 00:02:37

Também vamos aproveitar que tivemos todo esse trabalho para observar a tabela BGP do PE1, já que assim fica evidente a importância do identificador RD.

PE1#show ip bgp vpnv4 all
BGP table version is 17, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 65001:111 (default for vrf Cliente1)
*> 172.16.1.0/30    0.0.0.0                  0         32768 ?
*>i172.16.3.0/30    2.2.2.2                  0    100      0 ?
*> 192.168.1.0      172.16.1.2         2172416         32768 ?
*>i192.168.2.0      2.2.2.2            2172416    100      0 ?
Route Distinguisher: 65002:222 (default for vrf Cliente2)
*> 172.16.2.0/30    0.0.0.0                  0         32768 ?
*>i172.16.4.0/30    2.2.2.2                  0    100      0 ?
*> 192.168.1.0      172.16.2.2         2172416         32768 ?
*>i192.168.2.0      2.2.2.2            2172416    100      0 ?


Agora vamos observar a tabela de roteamento do roteador CE1A instalado na empresa. Observem que ele apenas conhece a rota remota como se as unidades estivessem diretamente conectadas entre si. Essa é a grande vantagem da implementação VPN do MPLS, afinal o cliente não enxerga a nuvem MPLS.

CE1A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.1.0 is directly connected, Serial2/0
D       172.16.3.0 [90/2681856] via 172.16.1.1, 00:08:33, Serial2/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
D    192.168.2.0/24 [90/2684416] via 172.16.1.1, 00:08:34, Serial2/0

 

Para finalizar esse post (que já está extenso demais), há vários comandos de exibição (show) que podemos utilizar para verificar o efeito de todas as configurações realizadas em cada uma das etapas.  Por isso deixo registrada uma relação de comandos de exibição caso o leitor queira reproduzir o cenário e sugiro uma observação detalhada das tabelas VRF e BGP.

PE1# show ip route
PE1# show ip route vrf Cliente1
PE1# show ip route vrf Cliente2
PE1# show ip bgp 
PE1# show ip bgp summary
PE1# show ip bgp vpnv4 all  
PE1# show ip eigrp vrf Cliente1 neighbors
PE1# show ip eigrp vrf Cliente2 neighbors
PE1# show ip eigrp vrf Cliente1 topology
PE1# show ip eigrp vrf Cliente2 topology   

Abraço.

Samuel.

28 comentários:

  1. Para aqueles que têm interesse em estudar mais sobre o assunto, recomendo o livro "Redes MPLS - Fundamentos e Aplicações" (link abaixo) do amigo Roberto Mendonça.


    http://www.brasport.com.br/informatica-e-tecnologia/rede/redes-mpls-fundamentos-e-aplicacoes.html

    ResponderExcluir
  2. Ótimo Post Samuel, Parabéns !!!
    Apesar retificando...o MPLS é uma tecnologia de Camada 2.5.



    Abração,


    Roberto Mendonça

    ResponderExcluir
    Respostas
    1. Corrigindo....Apenas retificando !!

      Excluir
    2. Ops, tem razão e já fiz a correção no post! Apenas para o leitor não ficar confuso, o datagrama IP é encapsulado com o cabeçalho MPLS e depois enquadrado com o cabeçalho de camada 2, ficando entre as camadas 3 e 2, por isso fazemos referência ao MPLS como sendo uma tecnologia de camada 2¹/² (ou 2,5).

      Ex.: < L2 | MPLS | L3 | PAYLOAD | L2 >

      Obrigado pela observação!

      Abraço.

      Excluir
  3. Adquiri o livro Redes MPLS - Fundamentos e Aplicações , e recomendo, é excelente!! No ambiente onde trabalho eu precisava muito de alguns esclarecimentos sobre VRF, address-family, etc. Parabéns aos autores.

    ResponderExcluir
  4. Ola,

    Gostaria de entender melhor como você fez para interligar as lans espetadas nos CE1A e CE2A, já que ambas estão na mesma rede /24. Você utilizou algum recurso para fazer VNPL2, (VPLS)?

    Erik

    ResponderExcluir
    Respostas
    1. Olá Erik.

      Repare no artigo que foram utilizadas VRFs distintas para cada cliente. A VRF consiste na criação de tabelas de roteamento independentes (virtuais) para cada cliente, ou seja, é mais uma tecnologia de virtualização na infraestrutura. É por isso que podem ser utilizados endereços repetidos da RFC1918 nos clientes que não há problema, afinal as VRFs são totalmente independentes.

      Abraço.

      Excluir
  5. É possivel fazer com o Cisco Packet Tracer?

    ResponderExcluir
    Respostas
    1. O Packet Tracer não tem suporte a MPLS. Esse cenário pode ser reproduzido com o GNS3.

      Excluir
  6. Olá Samuel
    Muito bom mesmo seu post. Aliás, o blog inteiro.

    Gostaria de ver se é possível postar uma explicação melhor sobre "address-family [ipv4] [vpnv4]".

    Abraço

    ResponderExcluir
    Respostas
    1. A address-family "ipv4" é utilizada para referenciar os endereços IP tradicionais, no formato XXX.XXX.XXX.XXX. A família "vpnv4" é utilizada para anexar o route-distinguisher ao endereço IP, no formato AS:RD:XXX.XXX.XXX.XXX.

      Excluir
  7. Quando inseri os comandos, o GNS3 alegou que eigrp não redistribui eigrp.

    ResponderExcluir
    Respostas
    1. Sugiro que você refaça todos os passos descritos no artigo com bastante atenção, uma vez que são vários comandos. Esse laboratório já foi reproduzido várias vezes e está funcionando normalmente.

      Excluir
  8. Em alguns cursos, citaram para não usar IGP nos CEs apenas nos PEs para redistribute seria o no auto sumary?

    ResponderExcluir
  9. Incrível o post, Parabéns Samuel.

    Abs!

    Reynaldo Silva

    ResponderExcluir
  10. Olá amigo,
    parabéns pelo post, mas tenho uma dúvida de como adicionar o "PROVIDER" na topologia. Ele é um equipamento que simula a nuvem? Onde e como posso inserir o "PROVIDER"
    Obrigado,
    Ícaro

    ResponderExcluir
    Respostas
    1. Na realidade a nuvem Provider é um simples roteador com suas respectivas configurações, mas com sua imagem original alterada para tornar a topologia mais didática.

      Excluir
  11. Viva Samuel Brito,
    ...o que seria "respectiva configurações" para poder atender as PEs.

    Obrigado,

    ResponderExcluir
  12. Olá Silvio!

    É só colocar um roteador de nome 'P' onde está a núvem.

    Depois basta conectar as interfaces físicas, e a lógica, com os PEs, e trocar as rotas via EIGRP na rede da provedora.

    Não esquecer do comando 'mpls ip' na config das interfaces físicas dentro da núvem. Não colocar mpls nas interfaces viradas para os clientes.

    P(config)# router eigrp 200
    P(config-router)# network 172.16.0.0
    P(config-router)# network 3.3.3.3
    P(config-router)# no auto-summary

    PE1(config)# router eigrp 200
    PE1(config-router)# network 172.16.0.0
    PE1(config-router)# network 1.1.1.1
    PE1(config-router)# no auto-summary

    PE2(config)# router eigrp 200
    PE2(config-router)# network 172.16.0.0
    PE2(config-router)# network 2.2.2.2
    PE2(config-router)# no auto-summary

    Abraço!

    ResponderExcluir
  13. Prezado. A partir de PE1 e PE2 eu não consigo mais pingar o IP da serial com cada cliente, após ativar as VRFs do passo 3. Mas se eu fizer o teste do ping a partir do lado de cada cliente, funciona. Saberia dizer por que e como fazer o PING respeitando a VRF do respectivo cliente?

    ResponderExcluir
  14. Boa tarde.

    Primeiro quero agradecer pela iniciativa. Muito bom!

    Se não for demais... Preciso saber se com os outros amigos que tentaram criar o LAB acima enfrentaram problema de conectividade dos PE1 e PE2 pela rede 172.16.0.0 tanto para o CE1A, CE2A como para os CE1B e CE2B. Consesguir pingar do CE´s par aos PEs mas dos PEs para os CE não consigo conectividade. Mesmo colocando uma rota estática não conseguia conectividade.

    ResponderExcluir
    Respostas
    1. vc ping do ce pro pe mas do PE o ping tem ser feito via vrf

      Excluir
  15. BOa noite Samuel,

    Você indicar o local de download de uma IOS que suporte MPLS, para jogar no GNS3 ?

    ResponderExcluir
  16. Olá muito bom seus posts

    PE1(config)#router eigrp 1
    PE1(config-router)#address-family ipv4 vrf Cliente1
    PE1(config-router-af)#autonomous-system 65001

    isso aqui não funcionou nos ios do 7200 do seu site? poderia informar as ios usadasa?

    ResponderExcluir
    Respostas
    1. Nesse laboratório foram utilizados roteadores da plataforma 3600. Recomendo que você baixe o laboratório de MPLS do meu livro já traz esse cenário pronto para o leitor fazer as configurações.

      Excluir
    2. tentei desse jeito usando o livro e os labs, mas não funciona o super putty não sei porque quando dou dois cliques no router ele tenta abrir o cli e falha, também estou usando interfaces fast ao invés de serial estou fazendo tudo do zero, vou usar 3600 dessa vez obrigado.

      Excluir
  17. não seria interessante startar um processo de EIGRP para cada um dos clientes? exemplo cliente X - eigrp 65000 cliente Y - eigrp 65001 no pe ?

    ResponderExcluir
  18. Tentei implementar por duas vezes, porem nao obtive exito, inclusive ate substituindo os router serie 7000 por 3600.

    ResponderExcluir