quinta-feira, 14 de março de 2013

Configuração de Switch Multi-Layer (Layer-3)

Olá Pessoal.

Nesse experimento o leitor aprenderá a configurar um Switch Multi-Layer (Layer-3) com algumas das principais características que diferenciam esse equipamento dos switches convencionais. Os switches multi-layer conseguem desempenhar tarefas de conectividade de redes locais que fazem os tradicionais swiches, além de serem capazes de realizar o roteamento de tráfego inter-redes que somente roteadores podem fazer.

Além disso, o desempenho de um switch multi-layer é "sempre" melhor do que o de qualquer roteador tradicional porque esses switches multi-layer têm alto desempenho, realizando todas as suas tarefas eletronicamente em hardware cuidadosamente projetado para esse fim. 



No cenário apresentado na figura acima é possível observar que existem quatro switches de acesso conectando suas respectivas máquinas terminais e existem duas VLANs (10 e 20). Os switches de acesso estão conectados a um Switch Multi-Layer que é responsável pela distribuição da conectividade entre toda a rede, além de realizar o roteamento inter-VLAN.

Uma característica interessante desse cenário é que os endereços de todas as máquinas da sub-rede 192.168.10.0/24 (associada à VLAN-10) e 192.168.20.0/24 (associada à VLAN-20) são distribuídos automaticamente via DHCP. Via de regra, como o serviço de DHCP funciona através do envio de broadcasts na rede para localizar um servidor, teríamos que ter um servidor DHCP exclusivo para cada sub-rede. No entanto, essa seria uma opção cara e inviável num ambiente com mais VLANs.

Para sanar esse problema o servidor DHCP será instalado em uma sub-rede administrativa à parte das sub-redes 192.168.10.0/24 e 192.168.20.0/24. Essa sub-rede estará vinculada à VLAN-1 (padrão) e para permitir que o tráfego de broadcast gerado pelas máquinas no momento da solicitação de endreços chegue até o servidor, é necessário configurar uma função denominada relay-agent no switch/roteador para que ele saiba que deve reencaminhar todo tráfego de broadcast até o endereço específico do servidor DHCP na rede admnistrativa.   

Cabe destacar que o servidor DHCP utilizado nesse laboratório já está devidamente configurado com os escopos corretos para oferecer endereços às sub-redes. O servidor também já possui um IP 192.168.0.1/24 atribuído a ele e seu gateway está configurado como sendo o endereço 192.168.0.254. Ou seja, a interface do switch que está conectada ao servidor terá que ser configurada para ser uma porta roteável (layer-3) capaz de receber esse IP.

Isso só pode ser feito em switches multi-layer que têm suporte a diferentes tipos de portas, o que torna esse equipamento bastante versátil. As portas de um switch multi-layer podem ser:

  • Porta de Camada 2: Essa é a porta convencional que possui as funcionalidades básicas de qualquer porta de um switch, por isso ela também é chamada e switchport. Por padrão, as portas dos switches multi-layer sempre estão nesse modo, exceto em equipamentos de maior porte utilizados no núcleo de grandes redes;
  • Porta de Camada 3: Através do comando "no switchport" na configuração da interface é possível transformá-la em uma porta de roteador, ou seja, uma porta roteável em que podemos configurar um IP. Por isso podemos dizer que um switch multi-layer é um roteador com alta densidade de portas, já que todas as suas portas podem rotear.
  • Porta Virtual de VLAN: Esse modo é interessante porque permite a criação de uma interface virtual vinculada a uma determinada VLAN, de maneira que essa interface lógica pode ser configurada com um IP que será o gateway de todas as máquinas que são membros dessa VLAN.

Obs.: Para que o leitor possa compreender melhor a aplicação prática de cada um desses tipos de portas, nesse laboratório serão configuradas todas essas opções.

Configuração do Switch Multi-Layer (Layer-3)

A configuração do Switch Multi-Layer no nosso cenário envolve vários aspectos e por isso exemplificarei essa configuração em etapas distintas para que o leitor compreenda melhor qual tarefa está associada com cada bloco de comandos.

Se observamos o comportamento do STP (Spanning Tree Protocol) depois que os switches já estão estáveis, é fácil identificar que o Switch DSW não foi eleito o switch raiz da rede. Com o intuito de criar uma rede robusta e simétrica com o melhor desempenho possível, faremos a configuração manualmente da prioridade do DSW para que ele seja o novo raíz da rede (spanning-tree vlan ID priority 0), conforme pode ser observado no primeiro bloco de comandos.

Apesar de switches multi-layer serem capazes de rotear entre redes, normalmente esse comportamento não está ativado por padrão e utilizaremos o comando "ip routing" para permitir explicitamente que ele faça roteamento entre as redes presentes em sua tabela de roteamento. Aproveitaremos essa etapa para já realizar as principais configurações de hostname, desativação da resolução de nomes, definição de um domínio de switches, criação de VLANs que serão utilizadas, etc. Caso o leitor não tenha conhecimento dessas configurações básicas, recomendo leitura prévia do Lab06 do livro "Laboratórios de Tecnologias Cisco"!

Switch> enable
Switch# configure terminal
Switch(config)# hostname DSW
DSW(config)# no ip domain lookup
DSW(config)# ip routing
DSW(config)# vtp mode server
DSW(config)# vtp domain AULA
DSW(config)# vtp password SENHA
DSW(config)# vlan 10
DSW(config-vlan)# name VLAN-10
DSW(config-vlan)# vlan 20
DSW(config-vlan)# name VLAN-20
DSW(config-vlan)# exit
DSW(config)# spanning-tree vlan 1,10,20 priority 0
DSW(config)#

Depois de realizadas essas configurações iniciais, na sequência converteremos a interface f0/10 (conectada ao servidor DHCP) para uma porta roteável (no switchport) e então atribuiremos a ela o endereço 192.168.0.254/24, já que esse foi o endereço de gateway configurado no servidor. Também criaremos duas interfaces lógicas vinculadas a cada uma das VLANs (interface vlan) do laboratório e configuraremos em cada uma delas um endereço IP que será o gateway das sub-redes associadas a suas respectivas VLANs. 

Nas interfaces lógicas também utilizaremos o comando "ip helper-address" para redirecionar o tráfego de broadcast gerado nas respectivas VLANs até o endereço do Servidor DHCP. Finalmente configuraremos as interfaces de f0/1 até f0/5 que interligam os demais switches de acesso para carregarem informações de todas s VLANs, em modo trunk.

DSW> enable
DSW# configure terminal
DSW(config)# int f0/10
DSW(config-if)# no switchport
DSW(config-if)# ip address 192.168.0.254 255.255.255.0
DSW(config-if)# int vlan 10
DSW(config-if)# ip address 192.168.10.254 255.255.255.0
DSW(config-if)# ip helper-address 192.168.0.1
DSW(config-if)# int vlan 20
DSW(config-if)# ip address 192.168.20.254 255.255.255.0
DSW(config-if)# ip helper-address 192.168.0.1
DSW(config-if)# int range f0/1 - 5
DSW(config-if-range)# switchport trunk encapsulation dot1q
DSW(config-if-range)# switchport mode trunk       

Obs.: A partir desse ponto o leitor pode utilizar o comando "show ip route" para exibir a tabela de rotas do switch multi-layer e constatar que já existem as sub-redes referentes às interfaces em que atribuímos IPs.

Para finalizar, repare que na interligação entre o DSW e o ASW4 utilizamos dois links redundantes de propósito para que possamos agora configurar uma agregação dos dois links, formando uma porta lógica (denominada port-channel) equivalente à soma das duas interfaces físicas, conforme comandos na sequência.

Isso é interessante para garantir maior largura de banda entre os switches através do balanceamento de carga entre os links físicos. Como o STP bloqueia uma das portas para evitar a ocorrência de loops, então um dos links físicas fica ocioso, o que pode ser ruim do ponto de vista de desempenho na rede. 

DSW> enable
DSW# configure terminal
DSW(config)# int range f0/4 - 5
DSW(config-if-range)# channel-group 1 mode on
DSW(config-if-range)# end
DSW#   

Obs.: Criaremos a port-channel manualmente e repare que repetiremos esse procedimento posteriormente nas portas f0/23 e f0/24 do ASW4. Também é interessante reparar que depois que criamos a porta lógica agregada, então o STP não bloqueia mais nenhum dos links individuais, já que para ele somente existe a porta lógica a partir dessa configuração...

Feitos os procedimentos anteriores, então nosso switch multi-layer está devidamente configurado. Na próxima etapa faremos as configurações dos demais switches de acesso para associar suas portas às suas respectivas VLANs.

Configuração dos Switches de Acesso Convencionais

A configuração dos demais switches de acesso é bastante simples e se resume apenas à inserção deles no domínio AULA (VTP) e à associação das portas com suas respectivas VLANs. Especificamente no ASW4 esteremos configurando manualmente a agregação com o DSW. Essas configurações são todas trazidas nos blocos abaixo:

Switch> enable
Switch# configure terminal
Switch(config)# hostname ASW1
ASW1(config)# no ip domain lookup
ASW1(config)# vtp domain AULA
ASW1(config)# vtp mode client
ASW1(config)# vtp password SENHA
ASW1(config)# interface f0/24
ASW1(config-if)# switchport mode trunk
ASW1(config-if)# interface f0/1
ASW1(config-if)# switchport mode access
ASW1(config-if)# switchport access vlan 10
ASW1(config-if)# interface f0/2
ASW1(config-if)# switchport mode access
ASW1(config-if)# switchport access vlan 20
ASW1(config-if)# end
ASW1#       

Switch> enable
Switch# configure terminal
Switch(config)# hostname ASW2
ASW2(config)# no ip domain lookup
ASW2(config)# vtp domain AULA
ASW2(config)# vtp mode client
ASW2(config)# vtp password SENHA
ASW2(config)# interface f0/24
ASW2(config-if)# switchport mode trunk
ASW2(config-if)# interface f0/1
ASW2(config-if)# switchport mode access
ASW2(config-if)# switchport access vlan 10
ASW2(config-if)# interface f0/2
ASW2(config-if)# switchport mode access
ASW2(config-if)# switchport access vlan 20
ASW2(config-if)# end
ASW2#        

Switch> enable
Switch# configure terminal
Switch(config)# hostname ASW3
ASW3(config)# no ip domain lookup
ASW3(config)# vtp domain AULA
ASW3(config)# vtp mode client
ASW3(config)# vtp password SENHA
ASW3(config)# interface f0/24
ASW3(config-if)# switchport mode trunk
ASW3(config-if)# interface f0/1
ASW3(config-if)# switchport mode access
ASW3(config-if)# switchport access vlan 10
ASW3(config-if)# interface f0/2
ASW3(config-if)# switchport mode access
ASW3(config-if)# switchport access vlan 20
ASW3(config-if)# end
ASW3#        

Switch> enable
Switch# configure terminal
Switch(config)# hostname ASW4
ASW4(config)# no ip domain lookup
ASW4(config)# vtp domain AULA
ASW4(config)# vtp mode client
ASW4(config)# vtp password SENHA
ASW4(config)# interface range f0/23 - 24
ASW4(config-if-range)# switchport mode trunk
ASW4(config-if-range)# channel-group 1 mode on
ASW4(config-if-range)# interface f0/1
ASW4(config-if)# switchport mode access
ASW4(config-if)# switchport access vlan 10
ASW4(config-if)# interface f0/2
ASW4(config-if)# switchport mode access
ASW4(config-if)# switchport access vlan 20
ASW4(config-if-range)# end
ASW4#      

Ótimo! Agora que já foram realizados os passos anteriormente descritos nessa atividade de laboratório, é de se esperar que o leitor tenha uma melhor compreensão dos aspectos práticos que envolvem a configuração de um Switch Multi-Layer (Layer-3). Os comandos abaixo podem ser utilizados para verificar o status das configurações:

Switch# show vlan
Switch# show interface trunk
Switch# show ip interface brief
Switch# show ip route
Switch# show ether-channel summary
Switch# show ether-channel port-channel 
  
Abraço.

Samuel.

38 comentários:

  1. Este comentário foi removido pelo autor.

    ResponderExcluir
    Respostas
    1. Olá Augusto.

      Sua dúvida foi removida, não sei se foi por acaso ou não... De qualquer forma a resposta que não há riscos de ocorrência de tempestade de broadcast em portas lógicas agregadas com o port-channel. Mesmo o STP não bloqueando as portas físicas, acontece que essas portas deixam de existir individualmente e passa a existir apenas a porta lógica agregada. Nesse caso, cabe ao alogoritmo do ether-channel geranciar as portas físicas para distribuir o tráfego e não permitir a ocorrência de loops.

      Abraço.

      Excluir
  2. Obrigado pela explicação amigo, pois fiz CCNA e na parte que fala sobre switchs de camada 3 a cisco dá a resposta que ela mais gosta:"A comutação multi-camada está fora do escopo deste curso." Portanto tirei muito proveito das informações passadas aqui.

    ResponderExcluir
    Respostas
    1. Olá Almeida.

      É bom saber que o blog está ajudando vocês leitores.Realmente o nível CCNA não aborda a operação de switches multi-layer, o que às vezes acaba tornando esse equipamento e seu modo de operação em algo distante para algumas pessoas.

      Abraço.

      Excluir
    2. Quando fiz o modelo 3.1 eu tive foram 3 aulas de 4 horas so sobre isso...uma pena os currículos dos cursos e das provas estarem tão diminuídos.....

      Excluir
  3. Por sinal eu não sabia que se poderia configurar a prioridade do STP para 0, pensei que era a partir do 4096.

    ResponderExcluir
  4. Caro Samuel

    Eu devo lhe agradecer bastante por este Post. veio de facto acalhar e na altura certa, Embora eu esteja ligeiramente tarde o meu comentarios.

    caro Samuel, eu quero comentar sobre este Post- apresentando uma pequena Questao que tem haver comigo (minha rede). e a questao é:

    Como é que eu posso fazer o routing between vlan na minha rede, tendo em conta que: tenho em minha rede Mais de 6 Bastidores (Racks) espalhados com varias Switches dentro delas, switches estas interligadas entre si e que recebem o sinal de internet via fibra Optica apartir da ligaçao principal que é uma Switch da serie 2960, a mesma serie das Switches espalhadas pela rede.

    Como é que seria o meu caso para criar as Vlans e o roteamento estático entre as Vlans?

    Com qual Switch-modelo, é que acha melhor fazer o roteamento?

    Desde ja agradeço vossa colaboraçao e muito obrigado.


    Saudaçoes



    Wagnet Tarso

    ResponderExcluir
    Respostas
    1. Wagnet,

      A família 2960 de switches é recomendada para ser utilizada somente na camada de acesso (nível do usuário) porque provê apenas conectividade de camada 2 com funções básicas de camada 3 (roteamento estático). Em projetos de redes hierárquicas essa família NÃO é empregada nas camadas de distribuição/core onde é feita a agregação de switches. Nesse caso sugiro que você faça uma busca pela Internet por outras opções recomendadas para esse fim, a exemplo de: 35XX, 37XX, 45XX, etc...

      A configuração em si não é diferente daquilo já abordado no livro e nesse post no que diz respeito a roteamento inter-VLANs e configuração de roteamento (estático e dinâmico). Se o ambiente for grande seria conveniente optar por roteamento dinâmico (requer troca de equipamento). Nesse caso você teria uma rota default no "roteador/switch" de borda conectado à Internet e poderia injetá-las no roteamento dinâmico. Enfim, a configuração vai depender do seu ambiente e dos equipamentos à sua disposição.

      Abraço.

      Excluir
  5. Boa Tarde Samuel
    Estou fazendo uns teste seguindo seu tutorial utilizando o trace, porem quando executo comando ip helper-address ip_do_server_dhcp. O comando é inexistente como pode ver abaixo.

    CORE(config-if)#ip helper-address 192.168.100.2
    ^
    % Invalid input detected at '^' marker.

    ResponderExcluir
    Respostas
    1. Olá Wesley.

      Qual versão do Packet Tracer você está utilizando? As versões mais antigas não tinham suporte ao comando "ip helper". É sempre recomendada a utilização da última versão disponível (atualmente é a 6.0.1).

      Abraço.

      Excluir
  6. Ola Professor Samuel!!

    Apesar deste post ser já de algum tempo.... mas seu tema continua ser bastante actual e actualizado nos dias de hoje.

    Relativamente a sua configuração inicial gostaria de perguntar o seguinte:

    1º- será que o bloco de comandos:

    #int fa 0/10
    #no switchport
    #ip address 192.168.0.254 255.255.255.0 anula automaticamente o comando por defeito:

    Int vlan 1
    Ip address 192.168.1.1 255.255.255.0 ??


    2- Por outro lado, será que é fundamental ou obrigatório que a interface do servidor dhcp que liga o switch Core deve estar direitamente conectado a esta Switch Core??

    Peço desculpas as minhas perguntas, tal como disse, sou novato nestas andanças.


    Chimena

    ResponderExcluir
    Respostas
    1. Suas dúvidas não ficaram claras... A interface f0/10 e a interface vlan1 são diferentes, não há relação entre elas. Nesse cenário específico o servidor DHCP faz parte de uma server-farm e está conectado no switch através da interface f0/10 (layer-3), por isso foi configurado um relay-agent nas interfaces do tipo VLAN (gateways das sub-redes) para direcionar o tráfego de broadcast até o endereço específico do servidor.

      Excluir
  7. Oi Samuel!!!

    Ok muito obrigado pela resposta..
    deu para perceber sim.. mas a outra pergunta que lhe fiz:

    É a de saber se obrigatorio que o servidor Dhcp esteja ligado ao Switch Core?

    No meu caso o meu servidor Dhcp nao està ligado direitamente na Switch Core... faz isso alguma diferença? Pois o meu dhcp está ligada numa switch de Acesso camada 2!!

    Saudaçoes


    Chimena

    ResponderExcluir
  8. Olá Samuel
    Obrigado pelo esclarecimento deu para tirar duvidas.
    Tenho a VLAN dos servidores 192.168.10.0 inclui o servidor DHCP.
    No layer3 quando criei as vlans ao atribuir IP na interface da Vlan servidores vem a mensagem de overlap.
    #inter vlan 10
    #ip address 192.168.10.1 255.255.255.0
    Overlaps with netwotk 192.168.10.0

    A intençao é que as portas 20 - 25 estejam na vlan dos servidores. os restantes das vlans estão a funcionar perfeitamente.
    Cumprimentos
    Sérgio

    ResponderExcluir
    Respostas
    1. Olá Sérgio,

      Não é permitido que você configure endereços na mesma sub-rede em múltiplas interfaces de um roteador (exceto através de virtualização de roteamento com a tecnologia VRF, não é seu caso). Verifique novamente suas configurações porque você já possui outra interface configurada na rede 192.168.10.0/24, além da VLAN 1. É provável que por engano você tenha atribuído o endereço 192.168.10.254 na interface f0/10, ao invés de 192.168.0.254.

      Abraço.

      Excluir
  9. Bom dia sr. Samuel

    Desculpe reviver o tópico :(, poderia esclarecer uma duvida?
    Um switch Layer 3 pode dispensar o uso de um roteador na rede ?

    Muito obrigado.

    ResponderExcluir
    Respostas
    1. Embora o Switch Layer-3 normalmente seja utilizado no núcleo da rede para fazer o roteamento entre as sub-redes internas (LAN), ele também pode ser utilizado como um roteador de borda (WAN) na rede. A abordagem mais comum é conectar os roteadores da operadora (comodato) nos Switches Layer-3 que compõem o núcleo das redes.

      Excluir
  10. Boa Tarde Prof: Samuel.

    Senhor poderia fazer uma video aula ou um tutorial com seguinte cenário para me ajudar faz um tempo que estou tentando solucionar esse cenário .

    1-moden adsl-ppoe com ip dinâmico
    1-moden cable com ip dinâmico
    1-Router
    1-Servidor DHCP
    1-Switch layer 3
    2-Switch 2960
    8-Pcs

    1º Os modens ligados no Router configurados load-balance.

    2º Router ligado no SWITCH LAYER-3 com 2 vlans por exemplo 10 e 20 porem é possível a comunicação entre as vlan 10 e 20 com apenas 2 portas do switch para essa função.


    3º Os dois SWITCH 2960 dividido entre a vlan 10 e 20 que se comunica entre si,com 4 Pcs cada, 2 pra cada vlan.

    4º O Servidor Dhcp ligado no Switch layer-3 gerando Dhcp pras duas vlans.

    obrigado

    ResponderExcluir
  11. Olá prezado Samuel,

    Tenho um Catalyst 4500-x e um C5K124-24 enterasys, atualmente extreme, gostaria de sabe como vou fazer um LACP entre os dois. Efetuei os comandos pardrões mas não comunica, o Port-channel10 que foi criado fica apenas "DOWN". Agradeço desde já.

    ResponderExcluir
  12. Como posso configurar o servidor para distribuir ip para cada vlan ?

    ResponderExcluir
  13. Essa configuracao ja tinha feito antes, facil.

    ResponderExcluir
  14. Samuel, fiz conforme o exemplo e funcionou praticamente tudo inclusive a distribuição de IP, porem as maquinas da Vlan 10 estao vendo a Vlan 20 e vice versa

    ResponderExcluir
    Respostas
    1. Sim, esse é o comportamento esperado porque o switch layer-3 está configurado para fazer roteamento entre as sub-redes das VLANs. Caso você queira isolar a comunicação, pode aplicar ACLs no próprio switch.

      Excluir
    2. Samuel obrigado pelo retorno, legal saber que funcionou, se importaria de me passar um exemplo de acl para isolar a lan 10 da 20 e ambas se comunicarem com o servidor?

      Excluir
    3. No Lab11 do livro Laboratórios de Tecnologias Cisco você encontra exemplos de como configurar uma ACL para negar a comunicação entre duas sub-redes.

      Excluir
  15. Samuel, ótimo blog.

    Fiquei na dúvida sobre a configuração dos switches de acesso!
    Eles não deveriam ter uma interface vlan para cada vlan e com um ip na mesma rede/subrede que as SVIs criadas no switch de distribuição?

    Outra coisa é sobre a configuração do servidor DHCP..
    É sempre feito dessa forma?

    ResponderExcluir
    Respostas
    1. A resposta da primeira pergunta é não, uma vez que os switches de acesso apenas conectam dispositivos terminais e, normalmente, a função de gateway das VLANs fica nas interfaces SVI dos switches de distribuição.

      Em relação à segunda pergunta a resposta é depende. Normalmente se faz assim, ou seja, o servidor DHCP fica isolado em sua própria server farm... No entanto, não precisa ser sempre assim.

      Excluir
  16. Entendi, muito obrigado Samuel.

    Em uma rede semelhante a sua do lab, imaginando que cada switch de tivesse uma vlan de gerencia na mesma subrede que o switch de distribuição, por que é necessário criar uma rota padrão em cada switch de acesso?

    ResponderExcluir
  17. Boa noite pessoal,
    Gostaria de uma ajuda eu tenho 3 switch cada um com 3 máquinas nas vlans 10,20,30 e um servidor na vlan 40.
    Só que quando eu coloco um roteador e configuro, ele faz o roteamento de todas as vlans entre elas, eu queria que fizesse da seguinte forma:

    Da vlan 10,20,30 para 40.

    Não sei se ficou muito claro.
    Obrigado desde já!

    ResponderExcluir
    Respostas
    1. Abacaxi.

      Quando se ativa o roteamento intervlan todas as vlan passam a se enchergar. Acredito que você possa resolver seu problema utilizando acl no roteador...

      Excluir
  18. Professor, li todo o material. Apenas confirmando: o comando "ip-helper address" vai informar que existe um serviço DHCP e que toda solicitação DHCP deve ser direcionada para o 192.168.0.1, certo?

    ResponderExcluir
    Respostas
    1. Sim, é quase isso... Na verdade o comando ip-helper faz com que todo tráfego de broadcast destinado à interface seja redirecionado para o endereço informado, independente de ser tráfego DHCP ou de outra natureza.

      Excluir
  19. Samuel, como vai tudo bem, não estou conseguindo executar o comando "IP helper-address (numero do servidor DHCP) No LAB packet Tracer no Layer 3560 a saida está como se o comando não existi:




    DSW2(vlan)#ip helper
    DSW2(vlan)#ip helper
    DSW2(vlan)#ip helper
    DSW2(vlan)#ip helper
    DSW2(vlan)#ip helper
    DSW2(vlan)#ip helper
    DSW2(vlan)#ip helper-
    DSW2(vlan)#ip helper-add
    DSW2(vlan)#ip helper-add
    DSW2(vlan)#ip helper-add
    DSW2(vlan)#helper?
    % Unrecognized command
    DSW2(vlan)#helper?
    % Unrecognized command
    DSW2(vlan)#helper?
    % Unrecognized command
    DSW2(vlan)#helper/?
    % Unrecognized command
    DSW2(vlan)#exit
    APPLY completed.
    Exiting....
    DSW2#cont
    DSW2#conf
    DSW2#configure t
    DSW2#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    DSW2(config)#int vl
    DSW2(config)#int vlan 10
    DSW2(config-if)#ip helper?
    % Unrecognized command
    DSW2(config-if)#ip helper-addr
    DSW2(config-if)#ip helper-addre
    DSW2(config-if)#ip helper-address 192.168.0.1

    ResponderExcluir
    Respostas
    1. Sugiro que você refaça o laboratório com atenção. Repare que logo no começo você estava tentando configurar o comando "ip helper-address" em sub-modo de configuração de VLAN, ao invés de fazê-lo no sub-modo de configuração de interface.

      Excluir
  20. Boa noite Prof. Samuel, estou com uma pequena duvida,

    como é possível haver comunicação entre os dois ipv6 abaixo tendo em
    conta que são de sub-redes diferentes. O mesmo acontece com ipv4 com
    sub-redes diferentes utilizando apenas o switches como intermediário.

    ex: 2001:db8:acad:2::2/64 com 2001:db8:acad:2::1/30


    ou mesmo ipv4

    192.168.0.1/24 com 192.168.0.2/25

    ResponderExcluir
  21. Maravilhoso laboratório muito esclarecedor, principalmente a configuração do ether-channel, vtp server e o roteamento das vlans. Você ajuda muita gente com seu trabalho, obrigado.

    ResponderExcluir