quarta-feira, 28 de setembro de 2016

Configuração de Ether-Channel e Trunk em Roteadores Cisco

Olá Pessoal,

Assim como a configuração de agregação de interfaces físicas é uma prática comum em links tronco (trunk) de switches para fins de disponibilidade e balanceamento de carga, essa mesma configuração é igualmente importante em roteadores que fazem roteamento inter-VLAN. Para exemplificar a configuração de uma agregação de links em roteadores Cisco, utilizarei o cenário apresentado na figura abaixo em que é necessário configurar roteamento inter-VLAN entre duas sub-redes compostas por máquinas de duas VLANs diferentes, de maneira similar ao exemplo que trago no Lab06 (intitulado Configuração de Switches e VLANs) do livro Laboratórios de Tecnologias Cisco.

A diferença é que no laboratório do livro o roteador está conectado ao switch através de uma única interface física, enquanto que nesse exemplo será configurada uma agregação lógica em duas interfaces físicas do roteadores. Essa prática não só é recomendada para fins de disponibilidade em caso de falha de um dos links, mas também para obter melhor desempenho porque múltiplas VLANs estão atreladas a um único trunk entre o switch e o roteador naquilo que chamamos de router on a stick


Nas linhas abaixo trago as configurações necessárias no roteador para que o roteamento inter-VLAN funcione no cenário proposto, com destaques em amarelo para aqueles comandos que remetem à configuração da agregação propriamente dita. 

Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# exit
Router(config)# interface range g0/0 - 1
Router(config-if-range)# channel-group 1
Router(config-if-range)# no shut
Router(config-if(range)# exit
Router(config)# interface po1.10
Router(config-subif)# encapsulation dot1q 10
Router(config-subif)# ip address 192.168.10.254 255.255.255.0
Router(config-subif)# exit
Router(config)# interface po1.20
Router(config-subif)# encapsulation dot1q 20
Router(config-subif)# ip address 192.168.20.254 255.255.255.0
Router(config-sub-if)# exit 
Router(config)# 

Para completar esse laboratório, abaixo trago as configurações do switch:

Switch# configure terminal
Switch(config)# vlan 10
Switch(config-vlan)# name VERDE
Switch(config-vlan)# exit
Switch(config)# vlan 20
Switch(config-vlan)# name VERMELHO
Switch(config-vlan)# exit
Switch(config)# interface range f0/1 - 3
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# exit
Switch(config)# interface range f0/4 - 6
Switch(config-if-range)# switchport access vlan 20
Switch(config-if-range)# exit
Switch(config)# interface range g0/1 - 2
Switch(config-if-range)# switchport mode trunk
Switch(config-if-range)# channel-group 1 mode on
Switch(config-if-range)# exit
Switch(config)# 

Façam seus testes...

Samuel. 

12 comentários:

  1. Cara demorou pacas pra eu entender uma coisa que parece ser óbvio mas não é... O ether-channel cria a agregação das interfaces numa interface virtual. Porém, nas duas pontas das portas, as configurações precisam estar exatamente iguais (como as configurações de duplex e velocidade por exemplo) para funcionar. Se alguma coisa estiver fora, no packet tracer por exemplo, as portas ficam como verdes mas o ether-channel não funciona e interface virtual entra no estado err-disable. Tomar cuidado com os detalhes. Ótimo artigo.

    ResponderExcluir
  2. Não faltou a configuração do channel no Switch? Da forma que foi configurado o STP não irá bloquear uns dos caminhos para o Router?

    ResponderExcluir
    Respostas
    1. Sim, você está correto!
      Acabei de fazer essa atualização no post.

      Excluir
  3. Boa tarde Samuel, estou montando o LAB pelo PacketTrace só que ao acessar a interface "Po1" para configurar a sub interface, me aparece esse erro:

    "Router(config-if)#interface po1.10
    ^
    % Invalid input detected at '^' marker."

    O que pode ser?

    Consigo criar as sub interfaces diretamente na interface física do router, mas no Port-channel eu não consigo.

    ResponderExcluir
    Respostas
    1. O Packet Tracer não suporta o recurso de sub-interfaces em Port-Channel. Você deve reproduzir esse cenário em equipamentos reais, por exemplo com um roteador 1905.

      Excluir
    2. Obrigado Professor Samuel. Tive a oportunidade de reproduzir essa configuração nesse mesmo roteador (1905) aqui na empresa e funcionou perfeitamente. Obrigado pela resposta.

      Parabéns pelo excelente Blog.

      Abração.

      Excluir
  4. Olá Professor.

    No segundo parágrafo seguanda frase, encontrei um erro ortgráfico:
    - "VLANs estão atraladas a um único trunk".

    e mais uma vez muito obrigado pelos seus artigos professor.
    Forte abraço
    Alexandre

    ResponderExcluir
  5. Professor estou tentando criar links PAgP e utilizando 3 Vlans mas não tive sucesso, minhas config na CLI> Switch 2960
    SW1
    #int range f022-24
    #channel-group 1 mode desirable
    #exit
    #int port-channel 1
    #switchport mode trunk
    #switchport trunk allowed vlan 10,20,30

    ResponderExcluir
    Respostas
    1. SW2
      #int range f022-24
      #channel-group 1 mode desirable
      #exit
      #int port-channel 1
      #switchport mode trunk
      #switchport trunk allowed vlan 10,20,30

      Excluir
  6. Professor o etherchannel funcionou!!! segui as config que fiz:
    SW1
    #int range f0/22-24
    #channel-group 1 mode desirable
    #switchport mode trunk
    #switchport trunk allowed vlan 10,20,30

    SW2
    #int range f0/22-24
    #channel-group 1 mode desirable
    #switchport mode trunk
    #switchport trunk allowed plan 10,20,30

    Isso funcionou pra mim, não sei se tem algo errado :)

    ResponderExcluir
  7. Excelente artigo como sempre: claro, direto e preciso! Força e Honra.

    ResponderExcluir