quarta-feira, 13 de julho de 2016

Configuração de MultiLink PPP em Roteadores Cisco

Olá Pessoal,

O MultiLink PPP (MLPPP) é uma tecnologia padronizada na RFC 1990 e na RFC 2686 que permite agregar múltiplos links físicos de longa distância (do tipo PPP) através de uma única interface lógica equivalente à soma das capacidades dos links individuais. Trata-se, portanto, de um recurso interessante para obter um link lógico de alta velocidade e com maior disponibilidade a partir de múltiplos links de baixa velocidade. Uma vez que o MLPPP requer configuração coerente em ambas as pontas com a informação de quais interfaces físicas devem ser logicamente agrupadas, não é possível utilizar esse recurso para agregar múltiplos links físicos que sejam providos por diferentes operadoras.

O pré-requisito óbvio para configurar MLPPP é a existência dos links físicos PPP. A configuração do MLPPP é bastante simples, já que basta criar uma interface virtual do tipo multilink que receberá o endereço IP da rede ponto-a-ponto, além de ser referenciada como grupo lógico em cada uma das interfaces físicas. Tomando por base a topologia ilustrada na figura acima, as configurações necessárias estão destacadas abaixo em amarelo. As demais configurações consistem no estabelecimento dos links PPP, assunto abordado em outro artigo intitulado "Configuração de Link WAN PPP em Roteadores Cisco"

R1(config)# username R2 password SENHA
R1(config)# interface s2/0
R1(config-if)# encapsulation ppp
R1(config-if)# ppp authentication chap
R1(config-if)# ppp multilink
R1(config-if)# ppp multilink group 1
R1(config-if)# no shut
R1(config-if)# interface s2/1
R1(config-if)# encapsulation ppp
R1(config-if)# ppp authentication chap
R1(config-if)# ppp multilink
R1(config-if)# ppp multilink group 1
R1(config-if)# no shut
R1(config-if)# interface multilink 1
R1(config-if)# ppp multilink
R1(config-if)# ip address 203.0.113.1 255.255.255.252

R2(config)# username R1 password SENHA
R2(config)# interface s2/0
R2(config-if)# encapsulation ppp
R2(config-if)# ppp authentication chap
R2(config-if)# ppp multilink
R2(config-if)# ppp multilink group 1
R2(config-if)# no shut
R2(config-if)# interface s2/1
R2(config-if)# encapsulation ppp
R2(config-if)# ppp authentication chap
R2(config-if)# ppp multilink
R2(config-if)# ppp multilink group 1
R2(config-if)# no shut
R2(config-if)# interface multilink 1
R2(config-if)# ppp multilink
R2(config-if)# ip address 203.0.113.2 255.255.255.252

Depois de realizadas as configurações do MLPPP, é possível observar que uma nova interface virtual do tipo multilink passa a compor a relação de interfaces do roteador. Também é possível observar na tabela de roteamento que a rede ponto-a-ponto entre os dois roteadores está diretamente conectada através da interface lógica multilink, ao invés das interfaces físicas do tipo serial.

R1# show ip route
Codes: (...)
Gateway of last resort is not set

     203.0.113.0/24 is variably subnetted, 2 subnets, 2 masks
C       203.0.113.2/32 is directly connected, Multilink1
C       203.0.113.0/30 is directly connected, Multilink1

O comando abaixo é específico para MLPPP e bastante útil para identificar quais interfaces físicas compõem o agrupamento lógico multilink, além de apresentar o status dessas interfaces. Nesse exemplo, é possível observar que ambas as interfaces físicas seriais estão operacionais.

R1# show ppp multilink 
Multilink1, bundle name is R2
  Username is R2
  Endpoint discriminator is R2
  Bundle up for 00:01:22, total bandwidth 3088, load 1/255
  Receive buffer limit 24000 bytes, frag timeout 1000 ms
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 6 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0x16 received sequence, 0x17 sent sequence
  Member links: 2 active, 0 inactive (max not set, min not set)
    Se2/0, since 00:03:25
    Se2/1, since 00:02:22
No inactive multilink interfaces

Para verificar a disponibilidade do agrupamento lógico, basta desativar qualquer uma das interfaces físicas seriais para simular um falha qualquer no link. Mesmo em caso de queda de um dos links físicos, a interface lógica se mantém disponível através do(s) outro(s) link(s) físico(s). Por exemplo, temos a seguinte saída após desativar a interface s2/1 em R2:

R1# show ppp multilink
Multilink1, bundle name is R2
  Username is R2
  Endpoint discriminator is R2
  Bundle up for 00:03:16, total bandwidth 1544, load 1/255
  Receive buffer limit 12000 bytes, frag timeout 1000 ms
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 12 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0x22 received sequence, 0x39 sent sequence
  Member links: 1 active, 1 inactive (max not set, min not set)
    Se2/0, since 00:05:20
    Se2/1 (inactive)
No inactive multilink interfaces

Façam seus testes...

Samuel.

111 comentários:

  1. Excelente postagem, muito bom professor.

    ResponderExcluir
  2. +LimmaoConsultoriaMarketingDigital LIMMAO Consultoria Marketing Digital

    Thank you for sharing in this article
    I can learn a lot and could also be a reference
    I am happy to find your website and can join to comment
    I think is very valuable to be able to read your writing, and on this occasion will I use for my reference source
    Thank you so much for sharing, I hope you continue to write spirit next topic

    Marketing Conteudo - O Que Faz um Consultor de Marketing - Consultoria Marketing

    ResponderExcluir
  3. your concept explanations are very well useful for me and i got clear process of this concept with fine explanation.

    Ccna Training in Chennai

    ResponderExcluir
  4. Muito bom. Alguém sabe por que aparece a opção authentication no multilink, se somente se usa nas seriais?

    ResponderExcluir
  5. Really it was an awesome article...very interesting to read..You have provided an nice article....Thanks for sharing..
    Android Training in Chennai
    Ios Training in Chennai

    ResponderExcluir
  6. Nice and beneficial share. it is very helpful for me to learn and endure regularly.. thanks for distributing your precious learning and time. please continue updating.

    AWS Training in HRBR Layout
    AWS Training in Kalyan Nagar
    Best AWS Training Institute in Kalyan Nagar Bangalore

    ResponderExcluir
  7. Needed to compose you a very little word to thank you yet again regarding the nice suggestions you’ve contributed here.
    amazon-web-services-training-in-bangalore

    ResponderExcluir
  8. Thanks a lot very much for the high your blog post quality and results-oriented help. I won’t think twice to endorse to anybody who wants and needs support about this area.
    datascience training in chennai

    ResponderExcluir

  9. This was an nice and amazing and the given contents were very useful and the precision has given here is good.
    Selenium Training Institute in Chennai

    ResponderExcluir
  10. Existing without the answers to the difficulties you’ve sorted out through this guide is a critical case, as well as the kind which could have badly affected my entire career if I had not discovered your website. digital marketing training in annanagar

    digital marketing training in marathahalli

    digital marketing training in rajajinagar

    Digital Marketing online training

    full stack developer training in pune

    ResponderExcluir

  11. It’s great to come across a blog every once in a while that isn’t the same out of date rehashed material. Fantastic read.

    Digital Marketing Training in Mumbai

    Six Sigma Training in Dubai

    Six Sigma Abu Dhabi

    ResponderExcluir
  12. It would have been the happiest moment for you,I mean if we have been waiting for something to happen and when it happens we forgot all hardwork and wait for getting that happened.
    python training in tambaram
    python training in annanagar
    python training in velachery

    ResponderExcluir
  13. Your good knowledge and kindness in playing with all the pieces were very useful. I don’t know what I would have done if I had not encountered such a step like this.
    Devops Training in pune

    Devops Training in Chennai

    Devops Training in Bangalore

    AWS Training in chennai

    AWS Training in bangalore





    ResponderExcluir
  14. Inspiring writings and I greatly admired what you have to say , I hope you continue to provide new ideas for us all and greetings success always for you..Keep update more information..

    rpa training in Chennai | rpa training in pune

    rpa training in tambaram | rpa training in sholinganallur

    rpa training in Chennai | rpa training in velachery

    rpa online training | rpa training in bangalore

    ResponderExcluir
  15. Thank you for allowing me to read it, welcome to the next in a recent article. And thanks for sharing the nice article, keep posting or updating news article.
    Blueprism training in annanagar

    Blueprism training in velachery

    Blueprism training in marathahalli

    ResponderExcluir
  16. Well somehow I got to read lots of articles on your blog. It’s amazing how interesting it is for me to visit you very often.
    Python training in usa
    Python training in marathahalli

    ResponderExcluir
  17. I found your blog while searching for the updates, I am happy to be here. Very useful content and also easily understandable providing.. Believe me I did wrote an post about tutorials for beginners with reference of your blog. 
    java online training | java training in pune

    java training in chennai | java training in bangalore

    ResponderExcluir

  18. Nice blog..! I really loved reading through this article. Thanks for sharing such a amazing post with us and keep blogging...


    Best Data Science online training in Hyderabad

    Data Science training in Hyderabad

    Data Science online training in Hyderabad

    ResponderExcluir
  19. Very nice post here and thanks for it .I always like and such a super contents of these post.Excellent and very cool idea and great content of different kinds of the valuable information's.
    Good discussion. Thank you.
    Anexas
    Six Sigma Training in Abu Dhabi
    Six Sigma Training in Dammam
    Six Sigma Training in Riyadh

    ResponderExcluir
  20. Were a gaggle of volunteers as well as starting off a brand new gumption within a community. Your blog furnished us precious details to be effective on. You've got completed any amazing work!
    java training in chennai | java training in bangalore

    java online training | java training in pune

    ResponderExcluir
  21. Wonderful article. Thanks for writing this type of article. Kindly Visit Us @ Rigid box

    ResponderExcluir
  22. Great Article… I love to read your articles because your writing style is too good, its is very very helpful for all of us and I never get bored while reading your article because, they are becomes a more and more interesting from the starting lines until the end.

    angularjs Training in bangalore

    angularjs Training in bangalore

    angularjs Training in btm

    angularjs Training in electronic-city

    angularjs online Training

    ResponderExcluir
  23. Information from this blog is very useful for me, am very happy to read this blog Kindly visit us @ Coimbatore Christmas Gift boxes | Wallet Box

    ResponderExcluir
  24. Amazing article. Your blog helped me to improve myself in many ways thanks for sharing this kind of wonderful informative blogs in live. I have bookmarked more article from this website. Such a nice blog you are providing ! Kindly Visit Us @ Best Travels in Madurai | Tours and Travels in Madurai

    ResponderExcluir
  25. Thanks For Your valuable posting, it was very informative

    Article submission sites
    Education

    ResponderExcluir
  26. Thanks for sharing this pretty post, it was good and helpful. Share more like this.

    eiffeltowerfacts
    Article submission sites

    ResponderExcluir
  27. Thanks for the great post on your blog, it really gives me an insight on this topic.I must thank you for this informative read. I hope you will post again soon.
    devops training near me
    devops training in chennai
    devops training and certification in bangalore
    best devops course in bangalore

    ResponderExcluir
  28. I want to thank you for this great blog! I really enjoying every little bit of it and I have you bookmarked to check out new stuff you post.
    website designing training
    web designing training
    web designing in chennai
    PHP Training in Chennai
    PHP Course in Chennai
    PHP Training Institute in Chennai

    ResponderExcluir
  29. Hi , thanks for sharing your information.The insights are really helpful and informative.
    Robotics in Coimbatore
    Learn robotics online

    ResponderExcluir
  30. Keep updating the blog, looking forward for more contents...Great job, keep it up. F5 ASM Training | F5 LTM Training

    ResponderExcluir

  31. It's interesting that many of the bloggers to helped clarify a few things for me as well as giving.Most of ideas can be nice content.The people to give them a good shake to get your point and across the command
    Data Science training in Chennai
    Data science training in Bangalore
    Data science training in pune
    Data science online training
    Data Science Interview questions and answers
    Data Science Tutorial
    Data science training in bangalore

    ResponderExcluir
  32. This blog is the general information for the feature. You got a good work for these blog.We have a developing our creative content of this mind.
    Thank you for this blog. This for very interesting and useful.
    Java training in Chennai
    Java training in Bangalore
    Java online training
    Java training in Pune
    Java training in Bangalore|best Java training in Bangalore

    ResponderExcluir
  33. You are doing a great job. I would like to appreciate your work for good accuracy
    Regards,
    Best Devops Training in Chennai | Best Devops Training Institute in Chennai

    ResponderExcluir
  34. Thanks For Sharing Your Information Please Keep Updating Us Time Went On Just Reading The Article Data Science Online Training

    ResponderExcluir
  35. This blog is very useful and informative. Thanks for sharing.
    SAS Certification

    ResponderExcluir
  36. Useful information.I am actual blessed to read this article.thanks for giving us this advantageous information.I acknowledge this post.
    Devops Training in Chennai | Devops Training Institute in Chennai

    ResponderExcluir
  37. Thank you for allowing me to read it, welcome to the next in a recent article. And thanks for sharing the nice article, keep posting or updating news article.
    Microsoft Azure online training
    Selenium online training
    Java online training
    Java Script online training
    Share Point online training

    ResponderExcluir
  38. This is really too useful and have more ideas and keep sharing many techniques. Eagerly waiting for your new blog keep doing more.
    Regards,
    Tableau training in Chennai | Tableau Courses Training in Chennai | Tableau training Institute in Chennai

    ResponderExcluir
  39. Thanks a lot very much for the high quality and results-oriented help. I won’t think twice to endorse your blog post to anybody who wants and needs support about this area.
    python training chennai|python training institute in chennai

    ResponderExcluir
  40. Este comentário foi removido pelo autor.

    ResponderExcluir
  41. Thanks For Sharing The Information The Information Shared Is Very Valuable Please Keep Updating Us Time Just Went On Reading The article Python Online Course Hadoop Online Course Aws Online Course Data Science Online Course

    ResponderExcluir




  42. And indeed, I’m just always astounded concerning the remarkable things served by you. Some four facts on this page are undeniably the most effective I’ve had.
    software Testing Training |Best Software Training Institute in Chennai



    ResponderExcluir
  43. Very well great blog post. This is a wonderful article, Given so much info in it, keep sharing.


    Data Science Bangalore

    ResponderExcluir
  44. This is a wonderful article, Given so much info in it, These type of articles keeps the users interest in the website, and keep on sharing more ... good luck.
    date analytics certification training courses
    data science courses training
    data analytics certification courses in Bangalore
    ExcelR Data science courses in Bangalore

    ResponderExcluir
  45. This is really good blog information thanks for sharing .I am really impressed with your writing abilities

    โปรโมชั่นGclub ของทางทีมงานตอนนี้แจกฟรีโบนัส 50%
    เพียงแค่คุณสมัคร Gclub กับทางทีมงานของเราเพียงเท่านั้น
    ร่วมมาเป็นส่วนหนึ่งกับเว็บไซต์คาสิโนออนไลน์ของเราได้เลยค่ะ
    สมัครสล็อตออนไลน์ >>> goldenslot
    สนใจร่วมลงทุนกับเรา สมัครเอเย่น Gclub คลิ๊กได้เลย

    ResponderExcluir
  46. I am really impressed with your post thank you for information


    เว็บไซต์คาสิโนออนไลน์ที่ได้คุณภาพอับดับ 1 ของประเทศ
    เป็นเว็บไซต์การพนันออนไลน์ที่มีคนมา สมัคร Gclub Royal1688
    และยังมีหวยให้คุณได้เล่น สมัครหวยออนไลน์ ได้เลย
    สมัครสมาชิกที่นี่ >>> Gclub Royal1688
    ร่วมลงทุนสมัครเอเย่นคาสิโนกับทีมงานของเราได้เลย

    ResponderExcluir
  47. I like viewing web sites which comprehend the price of delivering the excellent useful resource free of charge. I truly adored reading your posting. Thank you!
    Data Science Course in Pune

    ResponderExcluir
  48. I quite like reading an article that can make people think. Also, thanks for allowing for me to comment!
    data science course malaysia

    ResponderExcluir
  49. I wanted to leave a little comment to support you and wish you a good continuation. Wishing you the best of luck for all your blogging efforts.

    Data Science Course

    ResponderExcluir
  50. It’s great to come across a blog every once in a while that isn’t the same out of date rehashed material. Fantastic read.

    DevOps Training in Chennai
    Splunk Training in Chennai

    ResponderExcluir
  51. I just got to this amazing site not long ago. I was actually captured with the piece of resources you have got here. Big thumbs up for making such wonderful blog page digital marketing course in singapore

    ResponderExcluir
  52. Boa tarde! Alguém pode me ajudar? Não consigo utilizar o comando Router(config-if)#ppp multilink, aparece o erro:

    "% Invalid input detected at '^' marker."

    estou digitando desta forma

    Router(config)#interface se0/0/0
    Router(config-if)#encapsulation ppp
    Router(config-if)#ppp
    Router(config-if)#ppp authentication chap
    Router(config-if)#ppp multilink
    ^
    % Invalid input detected at '^' marker.


    obrigado.

    ResponderExcluir

  53. Nice information, valuable and excellent design, as share good stuff with good ideas and concepts, lots of great information and inspiration, both of which I need, thanks to offer such a helpful information here.
    www.technewworld.in
    How to Start A blog 2019
    Eid AL ADHA

    ResponderExcluir
  54. I just got to this amazing site not long ago. I was actually captured with the piece of resources you have got here. Big thumbs up for making such wonderful blog page! digital marketing course in singapore

    ResponderExcluir
  55. If you quote something a character says, use double quotation marks on the outside ends of the quotation to indicate that you are quoting a portion of the text. Use single quotation marks inside the double quotation marks to indicate that someone is speaking. "'Thou art not my child!1k daily profit review seo affiliate domination

    ResponderExcluir
  56. This is also a very good post which I really enjoyed reading. It is not every day that I have the possibility to see something like this,
    Data science Courses banglore

    ResponderExcluir

  57. Thanks for writing this great article. I’ve been using some of these techniques on by blog. But I didn’t know the phrase “Social Proof”. Thanks for sharing.
    One data science
    One Machine Learning

    ResponderExcluir

  58. Thanks for writing this great article. I’ve been using some of these techniques on by blog. But I didn’t know the phrase “Social Proof”. Thanks for sharing.
    One data science
    One Machine Learning

    ResponderExcluir
  59. This information really amazing thanks for share this article thank you..

    paheliyan

    ResponderExcluir