quarta-feira, 22 de junho de 2016

Lançamento do Cisco Packet Tracer 7.0

Olá Pessoal,

Hoje a Cisco anunciou oficialmente para a comunidade NetAcad o lançamento da nova versão do simulador Cisco Packet Tracer 7.0 (7.0.0.0202), disponível para download no repositório oficial da Academia Cisco (www.netacad.com). Dessa vez o simulador foi disponibilizado nas versões 32-bits e 64-bits em sistemas operacionais Windows e Linux. Na nova versão foram corrigidos vários bugs e adicionado/melhorado suporte a alguns recursos, além de novos dispositivos.


Os novos dispositivos podem ser observados na figura abaixo e estão relacionados principalmente a redes industriais no contexto de Internet of Things (IoT). Outra novidade é a possibilidade de integrar blocos de programação em Python e JavaScript nos dispositivos de IoT. Também houve mudança na interface do simulador, particularmente no agrupamento de dispositivos na paleta de componentes. Na sequência trago uma relação das melhorias anunciadas:

  • Melhoria no Servidor HTTP
  • Melhoria na Área de Trabalho da Topologia Física
  • Melhoria no Suporte a PoE
  • Suporte ao Recurso SPAN/RSPAN
  • Suporte ao Protocolo LLDP
  • Suporte a L2NAT
  • Precision Time Protocol (PTP)
  • Resilient Ethernet Protocol (REP)
  • Suporte a IoT (Internet of Things)
  • Novos Dispositivos

Fonte: Cisco Networking Academy

Os requisitos mínimos de sistema para executar o simulador são os seguintes:

  • Microsoft Windows (7 / 8.1 / 10) ou Linux Ubuntu (12.04 32-bits / 14.04 64-bits)
  • CPU Pentium 4 (2.5 GHz)
  • 512MB RAM
  • 400MB de Espaço em Disco
  • Resolução de Vídeo de 800x600

Está mantido o procedimento de login na inicialização do software que foi novidade na versão anterior (6.3.0008). Como já comentei no lançamento da versão anterior, o objetivo do login é priorizar os alunos matriculados em cursos das academias oficiais do programa Cisco Networking Academy (NetAcad). Para aqueles que não são alunos oficiais do programa NetAcad, ainda existe uma opção de login para visitantes (guest login) em que o usuário deve esperar por 15 segundos toda vez que inicializa o software antes de ser lançado para o simulador com algumas limitações de recursos. Embora ainda não seja possível afirmar, é natural de se pensar que a inserção da autenticação nessa nova versão do simulador seja um indicativo de que a Cisco pode restringir o acesso ao software em próximas versões somente para alunos da NetAcad, o que garantiria que as aulas seriam ministradas somente por instrutores oficiais habilitados pela Cisco. 

Como é de costume, também estou disponibilizando a nova versão do simulador Cisco Packet Tracer para download na seção "Downloads & Laboratórios" do blog (para Windows e Linux). Baixem essa nova versão e relatem suas experiências com a ferramenta. Os laboratórios do meu livro são todos compatíveis com essa nova versão, por isso não deve haver problema nenhum em fazer a atualização. Vale lembrar que os laboratórios criados nas versões mais recentes do Packet Tracer não são compatíveis com as versões anteriores. Por isso é sempre recomendado que os alunos tenham a versão mais recente do simulador instalado em suas máquinas.

Fiquem atentos...

Samuel.

33 comentários:

  1. O pacote denominado "Cisco-PT-7x64.tar.gz" pode ser utilizado para instalar o Packet Tracer 7 em diversas distribuições Linux. Para fazer a instalação a partir desse arquivo basta digitar os seguintes comandos, lembrando que o usuário deve ter privilégio de administrador (sudo):

    user@Linux:~$ tar -xvzf Cisco-PT-7x64.tar.gz
    user@Linux:~$ cd PacketTracer70
    user@Linux:~$ ./install

    Depois de instalado, para executá-lo:

    user@Linux:~$ packettracer

    ResponderExcluir
    Respostas
    1. Tentei instalar e aparentemente deu certo até o ./install, mas quando fui executá-lo aparece comando não encontrado

      Excluir
    2. Samuel boa tarde.

      Muito obrigado: funcionou até mesmo no Parrot!

      Abs,

      Excluir
    3. Ocorreu problema no lançador. Segue solução:

      # sudo nano /usr/share/applications/pt7.desktop

      Em "Exec=" corrija o nome para tudo em letra minuscula.

      Pois o lançador não encontra o "Packettracer", e sim "packettracer.

      Excluir
  2. legal esses dias subi rep em produção funciona muito bem, queria ter emulado antes mas foi simples a implantação, isso do login está com cara de cilada logo logo, o que acho meio falta de inteligência da cisco, tendo em vista que dando mais conhecimento de forma aberta ela continua bem no mercado que falemos a verdade eles já não dominam como antigamente...

    ResponderExcluir
  3. Obrigado pela partilha Gustavo...
    Será que este PT suporta EIGRP IPV6 e Authentication?

    ResponderExcluir
    Respostas
    1. O PT suporta as features básicas de EIGRP IPv6. Tenham em mente que aquilo que o simulador suporta está alinhado com o conteúdo cobrado no CCNA R&S. Não esperem suporte a recursos mais avançados que são cobrados no nível CCNP.

      Excluir
    2. sabe de algum netacad ead? fiz net acad faz uns 8 anos na época foi aplicado dentro de uma pós em redes, mudei de estado e aqui n tem nada sabe de algo abs

      Excluir
  4. Samuel, boa noite!
    Tentei instalar aqui no CentOS 7, porém o sistema não abre após a instalação. Tem alguma dica?
    Apenas exibe a mensagem: Starting Packet Tracer 7.0.

    Rafael

    ResponderExcluir
    Respostas
    1. Este comentário foi removido pelo autor.

      Excluir
    2. Devem estar faltando bibliotecas a serem instaladas. Para saber quais estão faltando execute:

      $ ldd /opt/pt/bin/PacketTracer7

      Instale as dependências e execute Packet Tracer novamente. Para executar sem precisar abrir o terminal, edite o arquivo:

      $ sudo vim /usr/share/applications/pt7.desktop
      [Desktop Entry]
      Version=1.0
      Exec=/opt/pt/packettracer
      Icon=/opt/pt/art/app.ico
      Type=Application
      Categories=Application;Network;
      Terminal=false
      Name=Cisco Packet Tracer 7.0

      Em seguida é preciso inserir permissão de execução:

      $ sudo chmod a+x /usr/share/applications/pt7.desktop

      Pronto, o Packer Tracer deve estar listado na categoria de Redes/Internet.

      Excluir
  5. estou com o mesmo problema =/

    ResponderExcluir
  6. Não estou conseguindo rodar no Linux Kali, alguma dica.

    ResponderExcluir
    Respostas
    1. Não estou conseguindo descobrir que erro você está encontrando, alguma dica?
      Tem algumas dicas, apenas leia (se possível) os comentários anteriores.

      Excluir
  7. Olá, instalei o Cisco no meu linux e está faltando a seguinte dependência:

    libcrypto.so.1.0.0

    Como faço para instalar a mesma?

    Agradecido.

    ResponderExcluir
    Respostas
    1. Tente utilizar o seguinte comando:

      sudo apt-get install libssl1.0.0 libssl1.0.0:i386

      Excluir
    2. Primeiro verifique se não existe a biblioteca instalada, localize com o comando:

      $ locate libcrypto

      Caso encontre basta copiar para a pasta de instalação do Packet Tracer (/opt/pt/lib/)

      Caso esteja usando Ubuntu, instale com o comando:

      $ sudo apt install libssl1.0.0

      Excluir
    3. Respondendo ao Samuel e o Mikael, segue o que apareceu ao digitar os comandos informados. Aliás, estou usando o Kali:



      root@kali:~# locate libcrypto
      /usr/lib/i386-linux-gnu/libcrypto++.so.6
      /usr/lib/i386-linux-gnu/libcrypto++.so.6.0.0
      /usr/lib/i386-linux-gnu/libcrypto.so.1.0.2
      /usr/lib/i386-linux-gnu/libcryptopp.so.6
      /usr/lib/i386-linux-gnu/i686/cmov/libcrypto.so.1.0.2
      /usr/share/doc/libcrypto++6
      /usr/share/doc/libcrypto++6/changelog.Debian.gz
      /usr/share/doc/libcrypto++6/copyright
      /var/lib/dpkg/info/libcrypto++6.list
      /var/lib/dpkg/info/libcrypto++6.md5sums
      /var/lib/dpkg/info/libcrypto++6.shlibs
      /var/lib/dpkg/info/libcrypto++6.triggers
      root@kali:~# apt-get install libssl1.0.0 libssl1.0.0:i386
      Lendo listas de pacotes... Pronto
      Construindo árvore de dependências
      Lendo informação de estado... Pronto
      O pacote libssl1.0.0 não está disponível, mas é referenciado por outro pacote.
      Isto pode significar que o pacote está faltando, ficou obsoleto ou
      está disponível somente a partir de outra fonte

      E: O pacote 'libssl1.0.0' não tem candidato para instalação
      E: O pacote 'libssl1.0.0' não tem candidato para instalação

      Excluir
    4. O arquivo /usr/lib/i386-linux-gnu/i686/cmov/libcrypto.so.1.0.2 seria um substituto mais recente do qual procuro? Posso copiar ele pra pasta do cisco ?

      Excluir
    5. Pra quem está com o mesmo problema que eu estava, consegui resolver baixando o arquivo pelo site abaixo. Aos que se disposeram a me ajudar, fico grato.

      https://packages.debian.org/wheezy/i386/libssl1.0.0/download

      Excluir
  8. Ola boia tarde!

    No meu Ubuntu apresenta este erro depois da instalação:

    Starting Packet Tracer 7.0
    /usr/local/bin/packettracer: linha 8: 5178 Abortado (imagem do núcleo gravada) ./PacketTracer7 "$@" > /dev/null 2>&1

    Como corrigir?

    ResponderExcluir
    Respostas
    1. Que pasta você instalou o Packet Tracer?

      A pasta padrão é /opt/pt e parece que ele não está encontrando o executável do programa, pois ele está entrando na pasta /usr/local/bin/

      Excluir
    2. Faça os seguintes comandos, como super usuário:

      # mv /opt/pt/packettracer /opt/pt/packettracer.backup
      # nano /opt/pt/packettracer

      Cole o seguinte conteúdo:

      #!/bin/bash

      echo Starting Packet Tracer 7.0

      PTDIR=/opt/pt
      export LD_LIBRARY_PATH=$PTDIR/lib
      pushd $PTDIR/bin > /dev/null
      ./PacketTracer7 "$@" > /dev/null 2>&1
      popd > /dev/null

      Salve, saia e abra o Packet Tracer.

      Excluir
  9. Este comentário foi removido pelo autor.

    ResponderExcluir
  10. Ola Mikael eu fiz o que vc recomendou! Mas ao executar apresentou este erro:

    root@Servidor:/home/frank_supremo/Downloads# packettracer
    bash: /usr/local/bin/packettracer: Permissão negada
    root@Servidor:/home/frank_supremo/Downloads# sudo packettracer
    sudo: packettracer: comando não encontrado

    grato desde ja

    ResponderExcluir
    Respostas
    1. Faltou dar permissão de execução ao arquivo criado, com o seguinte comando:

      $ sudo chmod 755 /usr/local/bin/packettracer
      $ sudo chmod 755 /opt/pt/packettracer

      Tente executar o PT.

      Excluir
    2. Ola boa noite!

      Continua com este problema:

      Starting Packet Tracer 7.0
      /usr/local/bin/packettracer: linha 8: 32614 Abortado (imagem do núcleo gravada) ./PacketTracer7 "$@" > /dev/null 2>&1

      Excluir
  11. Oi boa noite eu fiz como vc indicou e continuo apresentando erro

    ResponderExcluir
  12. Este comentário foi removido pelo autor.

    ResponderExcluir
  13. Boa noite, estou com o mesmo problema e já segui as dicas dos comentários acima. Pode me ajudar ?

    "Starting Packet Tracer 7.0
    /usr/local/bin/packettracer: line 9: 5631 Aborted ./PacketTracer7 "$@" > /dev/null 2>&1
    "

    ResponderExcluir
  14. Olá, parece existir algum problema de dependência na versão de 64 bits. Acabei de instalar a 32 bits e funcionou normalmente, ele baixou todas as dependências. Ainda não retornei à versão 64, mas vou tentar e posto o resultado. Infelizmente não tive tempo de buscar outras soluções. Abraço,

    ResponderExcluir
  15. Boa tarde, alguém mais está tendo problemas ao criar um servidor DNS?

    ResponderExcluir